Gaining Access to

IDEAS
The purpose of the ‘Information for Decision Enabling and Analysis System’ is to provide West Virginia University’s key policy makers with the capacity to make fact-based, strategic decisions.

The system has been designed, developed and supported by the Information Systems Database Administration and Administrative Systems Development units of the West Virginia University Office of Information Technology.

As the functional sponsor of the system, the Division of Planning champions the system's continued expansion and deployment to the University community.
<table>
<thead>
<tr>
<th></th>
<th>CONTENTS</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Stop Light Page</td>
<td>4</td>
</tr>
<tr>
<td>2</td>
<td>Login to IDEAS</td>
<td>5</td>
</tr>
<tr>
<td>3</td>
<td>Selecting Advanced Search</td>
<td>6</td>
</tr>
<tr>
<td>4</td>
<td>Creating a Connection</td>
<td>7</td>
</tr>
<tr>
<td>5</td>
<td>Connecting to Advance Search</td>
<td>10</td>
</tr>
<tr>
<td>6</td>
<td>Installing JInitiator</td>
<td>11</td>
</tr>
<tr>
<td>7</td>
<td>Choosing to build a new or run an existing query</td>
<td>17</td>
</tr>
<tr>
<td>8</td>
<td>Open an existing workbook</td>
<td>18</td>
</tr>
<tr>
<td>9.a</td>
<td>Create a new workbook</td>
<td>21</td>
</tr>
<tr>
<td>9.b</td>
<td>How to Select Items</td>
<td>29</td>
</tr>
<tr>
<td>9.c</td>
<td>Modify layout</td>
<td>30</td>
</tr>
<tr>
<td>9.d</td>
<td>Format Data</td>
<td>31</td>
</tr>
<tr>
<td>9.e</td>
<td>Conditions</td>
<td>32</td>
</tr>
<tr>
<td>9.f</td>
<td>Sort Data</td>
<td>35</td>
</tr>
<tr>
<td>9.g</td>
<td>Calculations</td>
<td>37</td>
</tr>
<tr>
<td>9.h</td>
<td>Percentages</td>
<td>38</td>
</tr>
<tr>
<td>9.i</td>
<td>Totals</td>
<td>41</td>
</tr>
<tr>
<td>9.j</td>
<td>Parameters</td>
<td>43</td>
</tr>
<tr>
<td>10</td>
<td>Edit worksheet</td>
<td>46</td>
</tr>
<tr>
<td>11</td>
<td>Refresh worksheet</td>
<td>47</td>
</tr>
<tr>
<td>12</td>
<td>Export worksheet</td>
<td>48</td>
</tr>
<tr>
<td>13</td>
<td>Share workbook</td>
<td>51</td>
</tr>
<tr>
<td>14</td>
<td>Change workbook settings</td>
<td>54</td>
</tr>
<tr>
<td>15</td>
<td>Appendix</td>
<td>55</td>
</tr>
<tr>
<td>15.a</td>
<td>The IDEAS Knowledge Repository</td>
<td>55</td>
</tr>
<tr>
<td>15.b</td>
<td>Examples</td>
<td>57</td>
</tr>
</tbody>
</table>
1. Stop Light Page
Type [http://ideas.wvu.edu](http://ideas.wvu.edu) in your address bar. If the light is green, IDEAS is available.

If you do not have a WVU Central ID, click on Acquire your Login ID and follow the instructions. If you do have a WVU Central ID, click on WVU Community Enter Here.
2. Login to IDEAS
The next screen requests your Central ID username and password. This is the same ID and password used for access to ENOD (electronic notification of deposit website).
3. Selecting Advanced Search
From the menu on the right, select Advanced Search to create new queries.
4. Creating a Connection

Clicking on **Advanced Search** will bring you to this window. If you are logging in for the first time you will not see an IDEAS connection link. You need to create this connection by clicking on the **Create Connection** button on the right.
4. Creating a Connection Continued.
Clicking on Create Connection will bring you to this window. Enter your username (first initial and last name) and a password of your choice. To connect to IDEAS enter the database name of BIDW. Then click Apply.
4. Creating a Connection Continued.
You should now see the link “IDEAS”. Click on this link to connect to Discoverer Plus.
5. Connecting to Advance Search
Enter your password and click on the Connect button.
6. Installing JInitiator
If you are logging in to IDEAS for the first time, you will have to install Oracle’s JInitiator. This is done only once per computer. The installation process may differ slightly depending on the version of the Windows operating system on your computer. For instance, if you are using Windows XP Service Pack 2, you will see the following screen. If you have a Pop-Up blocker, change the settings so that it accepts pop-ups from http://ideas.wvu.edu. Click on **Install ActiveX Control**… to install JInitiator.
6. Installing JInitiator continued.
You will see the following prompt. Click on **Install** to install Oracle JInitiator on your computer.
6. Installing JInitiator continued.
When this bar shows 100% please look for Oracle JInitiator Setup screen. Sometimes it is running in the back of other application windows, so you may need to minimize active windows to get to it.
6. Installing JInitiator, continued
The screen for Oracle JInitiator Setup will look like the following screen shot.

Keep hitting ‘Next’ until you see the following progress bar.
6. Installing JInitiator, continued
When this bar shows 100% please look for InstallShield Wizard Complete screen.
6. Installing JInitiator, continued
You will be prompted to restart your system now or restart later. Please save all your work before you
restart your machine. Its better that you restart your system after this installation, though restarting is not
a must. Click Finish to complete the installation.
7. Choosing to build a new query or run an existing query
Once JInitiator is installed, connecting to Advanced Search will bring you to this screen. Here you will choose to run an existing query or to build a new one.
8. Open an existing workbook
To view or modify an existing workbook, select “Open an existing workbook”. Select Database to open a workbook from the database.
8. Open an existing workbook, continued
From the list of available workbooks, select the workbook you want to open and click on the **Open** button.
8. Open an existing workbook, continued
The workbook opens in your account. You may view the results of the query, make modifications or save it in your account using **File->Save As**.
9: Create a new workbook

9.a: To create a new workbook, select “Create a new workbook”.
9.a.1: Layout

Select a layout to display information. **Table** is a good choice for beginners.
9.b.1: What is Available

A list of folders is displayed in the left panel of the window. To select an item from a folder click on the ‘+’ symbol next to the folder name to display all items in that folder.
9.b.2: Business Areas, Folders and Items

When working with Discoverer you use business areas, folders and items. The figure below shows the business areas, folders and items in the IDEAS data warehouse.
9.b.2 continued.

**Business Area:** A business area is a collection of related information in the data warehouse. In this case WVU IDEA is the business area.

**Folder:** Information within a business area is organized into folders. A folder contains closely related information. For instance within the WVU IDEA business area there are several folders such as Student Hepc containing Student Hepc data, the Major folder containing information about student majors.

**Items:** Different types of information within a folder are called items. For example, within the Student Hepc folder, some of the items are Act Composite Scores and Campus Code. Each item contains individual pieces of information. For instance, the Campus Code items can consist of a list of different campus codes.
### 9.b.2 continued: Brief Description of Folders in IDEAS

<table>
<thead>
<tr>
<th>Folder Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Student Census</td>
<td>Student Census data</td>
</tr>
<tr>
<td>Registration Census</td>
<td>Registration Census data</td>
</tr>
<tr>
<td>Course Census</td>
<td>Course Census data</td>
</tr>
<tr>
<td>Admit Type</td>
<td>Admit Type information</td>
</tr>
<tr>
<td>Advisor</td>
<td>Student Advisor information</td>
</tr>
<tr>
<td>Buildings</td>
<td>Buildings information</td>
</tr>
<tr>
<td>Cipc</td>
<td>Cipc information</td>
</tr>
<tr>
<td>College</td>
<td>College information</td>
</tr>
<tr>
<td>Degree</td>
<td>Student Degree information</td>
</tr>
<tr>
<td>Ethnic</td>
<td>Student Ethnicity information</td>
</tr>
<tr>
<td>High Schools</td>
<td>Student Census High School information</td>
</tr>
<tr>
<td>Major</td>
<td>Student Major information. Select Primary or Secondary major</td>
</tr>
<tr>
<td>Nation</td>
<td>Student Nation information. Select Legal, Mail or Permanent nation</td>
</tr>
<tr>
<td>Prev College</td>
<td>Student Previous College information</td>
</tr>
<tr>
<td>Student Hepc</td>
<td>Student Hepc data</td>
</tr>
<tr>
<td>Hepc High Schools</td>
<td>Student Hepc High School information from ACT High School Code</td>
</tr>
</tbody>
</table>

When you select an item from the Student Census folder, the Hepc High Schools folder is grayed out. You can select an item from this folder by first selecting an item from the Student Hepc folder.

When you select an item from the Student Hepc folder, all the following Student Census support folders will be grayed out: Admit Type, Advisor, Buildings, College, Degree, Ethnic, High Schools, Major, Nation, Prev College, Registration, and Course. To select an item from any of these folders you have to first select an item from the Student Census folder.
9.b.3 Limit the Time Frame of a Report

When you create a new query, you must always begin by selecting an item from one of the following: Student Census, Course Census, Registration Census, Admission Census…. fact tables, or the Student Hepc, Course Hepc, Registration Hepc fact tables.

In most cases, you should consider the time frame of the data of interest and select this value from the Student File Name item. All fact tables contain a Student File Name item where you will make this selection.
9.b.3: Item Description
To view a brief description of an item in a folder, click on the item name to highlight it. A brief description of the item will then appear at the bottom of the Edit Worksheet screen.
9.b.4: Select Items

Select items from the folder and move them to the selected list.
9.c: Modify Layout
You can change the layout of the report by clicking and dragging the column headings.
9.d: Format Data

Click on an item in the list to apply formats to that item. **Format Data** allows you to apply formats to the data. **Format Heading** allows you to apply formats to the heading. **Edit Heading** allows you to change the name of the data item so that it is displayed differently in the worksheet.
9.e.1: Conditions

Conditions allow you to limit worksheet results by criteria you specify. To create a new condition click on **New**. To edit a condition, select the condition and click on **Edit**. To delete a condition, select the condition and click on **Delete**.
9.e.2: Conditions, continued
Create a new condition by selecting an item on which you want the condition to be created from the drop down list, specifying the conditional operator and the values for that condition.
9.e.3: Conditions, continued

Once a condition has been created, it will appear in the list of conditions. Click in the check box next to the condition to activate the condition for the worksheet.
9.f.1: Sort

To Sort data in the worksheet, click on the Add button on the right.
9.f.2: Sort, continued

You will see the following Sort options. From ‘Column’ select the column on which you wish to sort. Select Direction as Low to High or High to Low. To Group Sort on the column you selected, click on Sort Type and select the Group Sort option. Delete a sort order by clicking on Delete.
9.g.1: Calculations

To create a new Calculation, Click on the New... button on the right to open the New Calculation dialog box.
9.g.2: Calculations, continued
New Calculation dialog box: Give a name to the calculation.
To add items to a calculation choose from Selected Items or Available Items from the Show drop down list.
To add functions choose Functions from the Show drop down list.
To add existing calculations choose Calculations from the Show drop down list.
To add mathematical operators, select an operator from below the Calculation field.
Click Paste to paste your selection in the Calculation field.
9.h.1: Percentages

Create Percentages to further analyze your data. Click on **New** to create a new Percentage.
9.h.2: Percentages, continued

New Percentage Dialog Box: Specify a name for the percentage, the data point on which you want to create a percentage, where to display the percentage etc.
9.i.1: Totals
Create Totals. Click **New** to create a new Total.
9.i.2: Totals, continued

New Total Dialog Box: Create a new total by selecting the data point on which you want to create the total, the kind of total (e.g. Sum, Avg), and the location of the total within the worksheet.
9.j.1: Parameters.
Create a parameter to prompt users to select or type values before running the worksheet.
9.j.2: Parameters, continued.
New Parameter dialog box: Specify the name of the parameter, the item you want to base the parameter on, the user prompt to be displayed, description of the parameter and default value if any. You can also specify if a user can enter multiple values for the parameter and also whether the parameter value is to be set for the current worksheet or all worksheets in the workbook.
9.j.3: Parameters, continued
After creating the Parameter Click **OK**. Click **Finish** to finish creating the worksheet.
10: Edit Worksheet
After clicking Finish, the query results are displayed in the worksheet. To edit the query, from the menu select Sheet-> Edit Sheet.
11: Refresh Worksheet
You can refresh the worksheet by re-querying the database. To do so, from the menu select Sheet-> Refresh Sheet or from the toolbar select the **orange arrow** (refresh button).
12: Export a worksheet: You can Export your data into any format.
   a) From the Menu select File->Export to HTML to export directly into HTML format.
   b) From the Menu select File->Export to Excel to export directly into Excel format.
   c) To export to any other format and have more control over the export process, from the Menu
      select File->Export. This will bring up the Export Wizard.
      You can export the current worksheet or all the worksheets.
12: Export continued.
Select the format you want to export to and the location where you want the file to be saved.
12: Export continued.
Select if you want to supervise the export process or not.
13: Share your workbooks with other users.
To share your workbook with other users, from the menu select **File->Manage Workbooks->Sharing**.
13: Sharing workbooks continued.
You will see the Share Workbooks dialog box. There are two ways to share your workbook with other users:

1) Select the workbook you want to share from the Workbook list box. Then from the ‘Available’ field select all the users you want to share it with and move them to the ‘Shared’ field. Then click OK.
13: Sharing workbooks continued.

2) Select the user with whom you want to share your workbook with from the User list box. Then from the ‘Available’ field select all the workbooks you want to share with and move them to the ‘Shared’ field. Then click OK.
14: Change workbook settings
From the Menu select **Tools-> Options** to bring up the Options Dialog Box.
You can now change various workbook settings. It is suggested to uncheck the “Limit retrieved query data to:” checkbox.
Appendix

15.a: The IDEAS Knowledge Repository

The IDEAS knowledge repository currently contains university student, registration, course information. In the future the repository will also incorporate student admission, recruitment and graduation information, and also personnel and financial information. The knowledge repository also contains a vast collection of university historical reports and also external links to various other knowledge sources.

Individuals with appropriate security profiles can access IDEAS to view the data and export it in a format that can be easily analyzed.

Oracle Discoverer 10g is an intuitive ad-hoc query, reporting, analysis, and Web-publishing tool that allows users to gain immediate access to information in the IDEAS data warehouse.

Contents of the IDEAS Knowledge Repository

IDEAS Dashboard Indicators

The IDEAS dashboard indicators are a vast array of university historical reports. The reports are broadly divided into the various categories such as Academics, Enrollment, Facilities, Faculty, Financial Aid, Personnel, and Research.

External peer comparison data

The IDEAS knowledge repository also contains links to several peer comparison data from external reporting systems – such as IPEDS, AAUP, and NASULGC.
**IDEAS Data Warehouse**

The data warehouse contains Census files and HEPC (Board) files.

**A census file** is an extraction of select Banner fields occurring on a routine schedule, usually daily. Census files reflect the contents of Banner at the moment the files are cut.

The current census files contained in IDEAS are generated each Monday morning.

**A static census file** is a file that is used as a basis for the official HEPC file. It is generated on the same date & time as the official HEPC file. A static census file does not change.

**HEPC files**, generally a subset of the census file, although some fields may be coded differently. These files are submitted to the Higher Education Policy Commission in accordance with the governing agency’s regulations. The HEPC files, like the static files used to create them, are a point-in-time snapshot of data. Student HEPC files, for example are cut on a pre-determined date in the beginning and at the end of Fall and Spring semesters. The summer student HEPC file is cut only at the end of the summer term.
15.b: Some Examples

a) MAJOR FEEDER LOCATIONS OF FIRST-TIME FRESHMEN
Fall 2000 to Fall 2004, West Virginia University, Morgantown Main Campus
Log into IDEAS and select the Create a new Workbook option.
Select the Page-Detail Crosstab Layout and Click Next.
From the Student Hepc folder select **Pidm Count**. The Personal ID Number or Pidm can be used to uniquely count students. Click on the ‘+’ symbol next to Pidm. You will see the Count/Max/Min functions below Pidm. Select Count and move it to the ‘Selected’ field list. Also select ‘**Reg Term Code**’ and ‘**State Foreign Country**’ from the Student folder.
Selected items. Click Next.
Since you have selected a Crosstab layout the data must be arranged appropriately. Click OK and the re-arrange your data.
Move ‘State Foreign Country’ to the left as shown below.
Click ‘Next’ until you see Step 5 of 9: Conditions.
The following conditions must be applied to this query:

a) ‘Type Of Registration’ = ‘First Time Freshmen’
c) ‘Student File Name’ IN (200008-102600-CensusBegin,200108-102201-CensusBegin,200208-092202-CensusBegin,200308-092503-CensusBegin,200408-092604-CensusBegin)
d) ‘Citizenship’ = ‘United States Citizen or Resident Alien’

Click ‘New’ to open the New Condition dialog box.
From the Item list box select the item ‘Type Of Registration’. If you do not see this click on ‘More Items…’ From the dialog box that is displayed select ‘Type Of Registration’. Select Condition equal to ‘=’. Click on Values to display a list of values. From the list select ‘First-Time Freshmen’. Click OK to create this condition.
If you want to give your condition a name, uncheck the ‘Generate name automatically’ check box and then type the desired name in the box below ‘What would you like to name your condition?’
Create all for conditions as shown below and click ‘Next’.
Click ‘Next’ until you reach Step 8 of 9: Totals. Click on ‘New’ to open the ‘New Total’ dialog box. Select Pidm COUNT as the data point on which you want the total to be created on. Select Sum as the total you want. Select the option so that the sum is displayed as ‘Grand total at bottom’. Click OK to create the total.
To Format the data, from the Menu select Sheet-> Edit Sheet. Then select the Format tab. You will see all the items that you can format. Select the item whose appearance you want to change. For instance, select ‘State Foreign Country’ and click on ‘Format Heading…’ You will see the Format Heading dialog box. You can now change the formats for this item.
b) Count of students who took courses in the Summer.

The Both Summer Flag indicates that a student attended both summer sessions.

i. To Select Students who took courses in Summer I only:

   Select a Summer I End-Of-Term file and set Both Summer Flag = ‘NULL’

ii. To Select Students who took courses in Summer II only:

   Select a Summer II End-Of-Term file and set Both Summer Flag = ‘NULL’

   Both Summer Flag and Summer Term Code are NULL for students who took courses in only one of the summer terms (i.e. did not take courses in both the summer terms)

iii. To Select Students who took courses in Both Summers:

   Select either a Summer I EOT file or a Summer II EOT file and Both Summer Flag = ‘Y’

   For students who took courses in both summers, Summer Term Code is equal to the Summer II Term Code.

iv. To get a unique count of all students who took courses in either of the Summer terms:

   Select both a Summer I EOT file and a Summer II EOT file and set Both Summer Flag equal to IS NULL. For students who took courses in both summers, Summer Term Code is equal to the Summer II Term Code.
Apply the following condition:

((Both Summer Flag IS NULL) AND (Student File Name IN "Summer II File Name") OR (Student File Name IN "Summer I File Name"). The condition can be created as shown below:
Questions?
For assistance or to request custom reports, please contact planning@mail.wvu.edu