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EXCEL TRAINING FOR ANALYSTS 
 

ADVANCED SESSION 

Convert numbers stored as text to numbers 

Occasionally, numbers may be formatted and stored in cells as text, which later can cause 
problems with calculations or produce confusing sort orders. For example, you may have typed a 
number in a cell that was formatted as text, or the data may have been imported or copied as text 
from an external data source. 

Numbers that are formatted as text are left-aligned instead of right-aligned in the cell. With error 
checking turned on, they are also marked with an error indicator.  
You can convert them to numbers by using the following steps: 
 
1. Select a blank cell that you know has the General number format.  

2. In the cell, type 1, and then press ENTER.  

3. Select the cell, and then click Copy on the Edit menu.  

4. Select the cells that contain the numbers stored as text that 
you want to convert.  

5. On the Edit menu, click Paste Special.  

6. Under Operation, click Multiply.  

7. Click OK.  
Back 

Convert numbers stored as numbers to text 

If you don't want numbers to be calculated, you can format them as text. A number that is 
formatted as text will be left-aligned instead of right-aligned. It will be stored as text and cannot 
be included in any calculation. 

1. Select the cells that contain the numbers that you want to format as text.  

2. On the Format menu, click Cells.  

3. On the Number tab, click Text in the Category list, and then click OK.  

Tip   Alternately, you can apply the Text format to the empty cells and then type the numbers. 
To use decimal places in numbers that are stored as text, you must include the decimal points 
when you type the numbers. 

Back 
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Conditional Formatting 

You can create conditional formats for selected cells using the following steps: 

1. Select the cells that contain the numbers that you want to format as text.  

2. On the Format menu, click Conditional Formatting… 

3. To use values in the selected cells as the formatting criteria, click Cell Value Is, select 
the Comparison Phrase you want, and then type a constant or a formula.  

4. Click Format.  

5. Select the formatting you want to 
apply when the cell value meets 
the condition or the formula 
returns the value TRUE.  

 

6. To add another condition, click Add, and then repeat steps 1 through 3.  

You can specify up to three conditions. If none of the specified conditions are true, the 
cells keep their existing formats. 

Note:  Using multiple conditions    If more than one specified condition is true, Microsoft 
Excel applies only the formats of the first true condition, even if more than one condition is 
true. 

Back 

 

“IF” Formulas 

Syntax 

IF(logical_test,value_if_true,value_if_false) 

Logical_test   is any value or expression that can be evaluated to TRUE or FALSE. For 
example, A10=100 is a logical expression; if the value in cell A10 is equal to 100, the expression 
evaluates to TRUE. Otherwise, the expression evaluates to FALSE.  

Value_if_true   is the value that is returned if logical_test is TRUE. For example, in the above 
example if A10 does equal 100 and you enter “Equal to 100” in the Value_if_true argument, then 
the IF function displays the text "Equal to 100". If logical_test is TRUE and value_if_true is 
blank, this argument returns 0 (zero). To display the word TRUE, use the logical value TRUE for 
this argument. Value_if_true can be another formula. 

Comparison Phrase Constant Value 
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Value_if_false   is the value that is returned if logical_test is FALSE. For example, if A10 does 
not equal 100 and you entered “Not equal to 100” in the Value_if_false argument, then the IF 
function displays the text "Not equal to 100". If logical_test is FALSE and value_if_false is 
omitted, (that is, after value_if_true, there is no comma), then the logical value FALSE is 
returned. If logical_test is FALSE and value_if_false is blank (that is, after value_if_true, there is 
a comma followed by the closing parenthesis), then the value 0 (zero) is returned. Value_if_false 
can be another formula. 

Back 

--Examples 

 

 

 

 

 

 

 

 



West Virginia University  Excel for Analysts 
Division of Planning   
 

- 6 - 

 

Linking Cells 
 
1. Click the cell that contains the data you want to link to, 

and then click Copy on the Standard Toolbar 

 

2. Click the cell you want to link from, and then under 
Format, click Paste Special.  

 

3. Click Paste Link.  
 
Note: The value in the linked cell will now change whenever the source cell’s value is changed. 
Back 
 
Hyperlink Cells 
 
1. In the source workbook, right-click the text or graphic you want to represent the hyperlink, 

and then click Hyperlink on the shortcut menu.  

2. Do one of the following:  

• To link to a location in your current workbook, click Place in this document 
under Link to. 

• To link to a location in another workbook, click Existing file or Web page under 
Link to. 

3. If you chose Existing file or Web page, locate and select the workbook you want to link to, 
and then click the Bookmark button.  

4. Do one of the following:  

• In the list under Cell Reference, click the sheet you want to link to, and then type 
the cell reference in the Type in the cell reference box. Click OK. 

• In the list under Defined Names, click the name that represents the cells you want 
to link to. Click OK. 

5. To assign a tip to be displayed when you rest the pointer on the hyperlink, click 
ScreenTip and then type the text you want in the ScreenTip text box. Click OK. 

 
Back 
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Filtering 

Filtering is a quick and easy way to find and work with a subset of data in a range. A filtered 
range displays only the rows that meet the criteria you specify for a column. Microsoft Excel 
provides two commands for filtering ranges: AutoFilter and Advanced Filter. 

Unlike sorting, filtering does not rearrange a range. Filtering temporarily hides rows you do not 
want displayed. When Excel filters rows, you can edit, format, chart, and print your range subset 
without rearranging or moving it. 

Back 

Auto Filter 
 
To use the Auto Filter command on a subset of data, from the Data menu, click Auto Filter.  
Your subset must contain Headers for the Auto Filter to work properly. 
 
When you use the AutoFilter command, AutoFilter 
arrows  appear to the right of the column labels in the 
filtered range. 
 
To apply a filter, click on an Auto Filter arrow and 
select a category/value to filter for.  The Auto Filter 
arrow will change to a blue triangle to let you know that 
a filter is applied. 
 
TIP: You can filter more than one column at a time 
 
 
 
 
To apply a Custom Filter, click on 
an Auto Filter arrow and then click 
(Custom…).  In the Custom Auto 
Filter box, use the drop-down menu 
to select your criterion.   
 
You can use more than one condition 
to filter your data.  This example 
filters for numbers greater than 12 
and less than 20.   
 
Click OK to apply the filter. 
Back 
 
Filter for Unique Records 
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1. Select the column or click a cell in the range or list you want to filter.  

2. On the Data menu, point to Filter, and then click Advanced Filter.  

3. Do one of the following.  

• To filter the range or list in place, similar to using AutoFilter, click Filter the list, in-
place.  

• To copy the results of the filter to another location, click Copy to another location. 
Then, in the Copy To box, enter a cell reference.  

To select a cell, click Collapse Dialog to temporarily hide the dialog box. Select the cell on 
the worksheet, and then press Expand Dialog . 

4. Select the Unique records only check box.  

Note   Once you filter for unique values, you can copy them to another worksheet and then 
archive or delete the original worksheet. 

Back 

 

 

 

 

Pivot Table Reports 

Use the following steps to create a Pivot Table Report: 

1. Open the workbook where you want to create 
the Pivot Table Report and click a cell in the 
list or database.  Note: Each column in your 
spreadsheet must have a heading in order to 
produce a pivot table. 

2. On the Data menu, click PivotTable and 
PivotChart Report.  

 

3. In step 1 of the PivotTable and 
PivotChart Wizard, accept both of the 
default options—Microsoft Office Excel 
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list or database and Pivot Table. Click 
Next 

 

4. In step 2, make sure the range of your data is 
correct.  Excel will choose a range based on 
how your spreadsheet is set up. Click         
Next. 

 

5. In step 3, accept the default option of placing 
the Pivot Table in a New worksheet.  Click 
Finish. 

 

 
 
 
A new sheet will be created with a blank Pivot Table similar to the one on the next page. 
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6. From the PivotTable Field List window, drag the fields with data that you want to 
display in rows to the drop area labeled Drop Row Fields Here.  

If you don't see the field list, click within the outlines of the PivotTable drop areas. 

7. Drag fields with data that you want to display across columns to the drop area labeled 
Drop Column Fields Here.  

8. Drag fields that contain the data that you want to summarize to the area labeled Drop 
Data Items Here.  

If you add more than one data field, arrange these fields in the order you want: Right-
click a data field, point to Order on the shortcut menu, and use the commands on the 
Order menu to move the field. 

List of Fields 
Click and drag 
to Pivot Table 
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9. Drag fields that you want to use as page fields to the area labeled Drop Page Fields Here.  

To rearrange fields, drag them from one area to another. To remove a field, drag it out of 
the PivotTable report.  

To hide the drop area outlines, click a cell outside the PivotTable report. 

The following Pivot Table example summarizes the number of employees by Gender and Job 
Type: 

 
The following Pivot Table example summarizes the number of CL employees by Race, Gender 
and Pay Year Type: 
 

 
 
 

Back 
 
 
 
 
 
 
 
 
 



West Virginia University  Excel for Analysts 
Division of Planning   
 

- 12 - 

Vlookups 

Searches for a value in the first column of a table array and returns a value in the same row from 
another column in the table array.  

The V in VLOOKUP stands for vertical. Use VLOOKUP instead of HLOOKUP when your 
comparison values are located in a column to the left of the data that you want to find. 

Syntax 

VLOOKUP(lookup_value,table_array,col_index_num,range_lookup) 

Lookup_value  The value to search in the first column of the table array. Lookup_value can be a 
value or a reference. If lookup_value is smaller than the smallest value in the first column of 
table_array, VLOOKUP returns the #N/A error value. 

Table_array  Two or more columns of data. Use a reference to a range or a range name. The 
values in the first column of table_array are the values searched by lookup_value. These values 
can be text, numbers, or logical values. Uppercase and lowercase text are equivalent.  

Col_index_num  The column number in table_array from which the matching value must be 
returned. A col_index_num of 1 returns the value in the first column in table_array; a 
col_index_num of 2 returns the value in the second column in table_array, and so on. If 
col_index_num is: 

 

 Less than 1, VLOOKUP returns the #VALUE! error value.  
 

 Greater than the number of columns in table_array, VLOOKUP returns the #REF! error 
value. 

Range_lookup  A logical value that specifies whether you want VLOOKUP to find an exact 
match or an approximate match: 

 

 If TRUE or omitted, an exact or approximate match is returned. If an exact match is not 
found, the next largest value that is less than lookup_value is returned.  

The values in the first column of table_array must be placed in ascending sort order; otherwise, 
VLOOKUP may not give the correct value. You can put the values in ascending order by 
choosing the Sort command from the Data menu and selecting Ascending.  

 

 If FALSE, VLOOKUP will only find an exact match. In this case, the values in the first 
column of table_array do not need to be sorted. If there are two or more values in the first 
column of table_array that match the lookup_value, the first value found is used. If an exact 
match is not found, the error value #N/A is returned. 

 

 TIP: You can use a formula to prevent #N/A values from appearing.  The following is an 
example of one such formula: 

=if(isna(vlookup(A2,Sheet1!A:D,4,0))=true,”Value Not Found”, vlookup(A2,Sheet1!A:D,4,0)) 
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The formula basically states that if you don’t get an exact match, return “Value Not Found”, 
instead of #N/A. 

Remarks  
 

 When searching text values in the first column of table_array, ensure that the data in the 
first column of table_array does not have leading spaces, trailing spaces, inconsistent use of 
straight ( ' or " ) and curly ( ‘ or “) quotation marks, or nonprinting characters. In these cases, 
VLOOKUP may give an incorrect or unexpected value.  

 

 When searching number or date values, ensure that the data in the first column of 
table_array is not stored as text values. In this case, VLOOKUP may give an incorrect or 
unexpected value.  

 

 If range_lookup is FALSE and lookup_value is text, then you can use the wildcard 
characters, question mark (?) and asterisk (*), in lookup_value. A question mark matches any 
single character; an asterisk matches any sequence of characters. If you want to find an actual 
question mark or asterisk, type a tilde (~) preceding the character. 

 

Vlookup Example for Exact Match: 
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Vlookup Example for Approximate Match: 

 

 

Back 

Hlookups 

Searches for a value in the top row of a table or an 
arrayjavascript:AppendPopup(this,'xldefArray_1') of values, and then returns a value in the same 
column from a row you specify in the table or array. Use HLOOKUP when your comparison 
values are located in a row across the top of a table of data, and you want to look down a 
specified number of rows. Use VLOOKUP when your comparison values are located in a 
column to the left of the data you want to find. 

The H in HLOOKUP stands for "Horizontal." 

Syntax 

HLOOKUP(lookup_value,table_array,row_index_num,range_lookup) 

Lookup_value   is the value to be found in the first row of the table. Lookup_value can be a 
value, a reference, or a text string. 

Table_array   is a table of information in which data is looked up. Use a reference to a range or 
a range name. 

 

 The values in the first row of table_array can be text, numbers, or logical values. 

 

 If range_lookup is TRUE, the values in the first row of table_array must be placed in 
ascending order: ...-2, -1, 0, 1, 2,... , A-Z, FALSE, TRUE; otherwise, HLOOKUP may not give 
the correct value. If range_lookup is FALSE, table_array does not need to be sorted. 

javascript:AppendPopup(this,'xldefArray_1')�
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 Uppercase and lowercase text are equivalent. 

 

 You can put values in ascending order, left to right, by selecting the values and then 
clicking Sort on the Data menu. Click Options, click Sort left to right, and then click OK. 
Under Sort by, click the row in the list, and then click Ascending. 

Row_index_num   is the row number in table_array from which the matching value will be 
returned. A row_index_num of 1 returns the first row value in table_array, a row_index_num of 
2 returns the second row value in table_array, and so on. If row_index_num is less than 1, 
HLOOKUP returns the #VALUE! error value; if row_index_num is greater than the number of 
rows on table_array, HLOOKUP returns the #REF! error value. 

Range_lookup   is a logical value that specifies whether you want HLOOKUP to find an exact 
match or an approximate match. If TRUE or omitted, an approximate match is returned. In other 
words, if an exact match is not found, the next largest value that is less than lookup_value is 
returned. If FALSE, HLOOKUP will find an exact match. If one is not found, the error value 
#N/A is returned. 

Back 

Tools 

Protect Sheet 

Lock All Cells 

To protect your worksheet by locking all cells, complete the following steps: 

1. While in the worksheet you want protected, go to the 
Tools menu, point to Protection, and then click 
Protect Sheet. 

2. Accept the default choices of “Protect worksheet 
and contents of locked cells”, “Select locked 
cells” and “Select unlocked cells.” 

3. Enter a password that you will remember and 
click OK. 

4. Enter the same password on the next screen and 
click OK. 

Back 

Lock Selected Cells 

To lock certain cells within a worksheet, complete the following steps: 
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1. Select the entire worksheet by clicking the Select All button (the gray rectangle directly 
above the row number for row 1 and to the left of column letter A).  

2. Click Cells on the Format menu, click the Protection tab, and then clear the Locked 
check box.  

This unlocks all the cells on the worksheet 

Note  If the Cells command is not available, parts of the worksheet may already be locked. 
On the Tools menu, point to Protection, and then click Unprotect Sheet. 

3. Select just the cells you want to lock and repeat step 2, but this time select the Locked 
check box.  

4. On the Tools menu, point to Protection, click Protect Sheet, and then click OK.  

Note  In the Protect Sheet dialog box, you have the option to specify a password and select 
the elements that you want users to be able to change. 

Back 

 
Manual Calculation 
 
If you are working with large amounts of data with thousands of calculations (especially 
Vlookups and/or links to other 
workbooks), you may notice that Excel 
will “slow down” in order to perform all 
vlookups and other calculations.  One 
way to eliminate this problem is to set 
Excel to Manual Recalculation mode.  
This can be done by completing the 
following steps: 
1. On the Tools menu, click Options, 

and then click the Calculation tab.  

2. Under Calculation, select Manual. 
Changing this option affects all open 
workbooks.  Click OK. 

3.  To calculate all worksheets in all 
open workbooks press F9. 

To calculate only the active 
worksheet, press SHIFT+F9. 

Back 
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Validation 
To make data entry easier, or to limit entries to certain items that you define, you 
can create a drop-down list of valid entries that is compiled from cells elsewhere on 
the worksheet. When you create a drop-down list for a cell, it displays an arrow 
next to that cell. To enter information in that cell, click the arrow, and then click the 
entry that you want.  

To create a drop-down list from a range of cells, use the Validation command under the Data 
menu. 

1. To create a list of valid entries for the drop-down list, type the entries in a single column or 
row without blank cells.  

Note-you may want to sort the data in the order you want it to appear in the drop-down list. 

2. If you want to use a different worksheet in the same workbook, type the list on that 
worksheet, and then define a name for the list (Insert, Name, Define) 

3. Select the cell where you want 
the drop-down list.  

4. On the Data menu, click 
Validation, and then click the 
Settings tab.  

5. In the Allow box, click List.  

6. To specify the location of the list 
of valid entries, do one of the 
following:  

a. If the list is in the current 
worksheet, enter a reference to 
your list in the Source box.  

b. If the list is on a different 
worksheet in the same 
workbook or a different 
workbook, enter the name that 
you defined for your list in the Source box preceded with an equal sign (=). 

7. Make sure that the In-cell drop-down check box is selected.  

8. To specify whether the cell can be left blank, select or clear the Ignore blank check box.  If 
this box is selected, users can leave the cell blank. 

9. Optionally, display an input message when the cell is clicked.  To do this: 

• Click the Input Message tab.  
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• Make sure that the Show input message when cell is selected check box is selected.  

• Type the title and text for the message (up to 225 characters). 

10. Optionally, you can specify how you want Microsoft Office Excel to respond when invalid 
data is entered. 

• Click the Error Alert tab, and make sure that the Show error alert after invalid 
data is entered check box is selected.  

• Select one of the following options for the Style box:  

o To display an information message that does not prevent entry of invalid 
data, click Information.  

o To display a warning message that does not prevent entry of invalid data, 
click Warning.  

o To prevent entry of invalid data, click Stop. 

• Type the title and text for the message (up to 225 characters).  

Note  If you don't enter a title or text, the title defaults to "Microsoft Excel" and the 
message to: "The value you entered is not valid. A user has restricted values that can be 
entered into this cell." 

Back 

 
 
Charts 
You can quickly create a chart in Microsoft Excel by using the Chart Wizard. In this wizard, you 
can choose from a variety of chart types and specify various chart options. Although worksheet 
data that you want to plot in a chart can be located in rows or columns, some chart types require 
a specific arrangement of the data before you can create a chart. 

1. On the worksheet, arrange the data that you want to plot in a chart.  

2. Select the cells that contain the data that you want to use for the chart.  

Tip  If the cells that you want to select for the chart are not in a continuous range, select the 
first group of cells that contain the data that you want to include. Hold down CTRL, and then 
select any additional cell groups that you want to include. The nonadjacent selections must 
form a rectangle.  

3. Click Chart Wizard on the Standard toolbar, or click Chart on the Insert menu.  

4. Follow the instructions in the Chart Wizard.  

For information about the Chart Wizard options, click Help in the title bar of the wizard. 
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Tip  If you use a specific chart type frequently when you create a chart, you may want to set that 
chart type as the default chart type. To change the default chart type: 

1. Click anywhere in the chart area to select the chart.  

2. On the Chart menu, click Chart Type.  

3. On the Standard Types tab or Custom Types tab, in the Chart type list, click the chart 
type that you want or accept the current selection, and then click Set As Default Chart.  

4. Click Yes, and then click OK.  

5. If the Add Custom Chart Type dialog box appears, type a name in the Name box and a 
description in the Description box, and then click OK. 

Notes  
 

 When you create a chart, the Chart toolbar is displayed and the Chart menu is added to 
the menu bar. You can use the toolbar buttons and menu commands to modify the chart. For 
example, use the toolbar to select specific items in the chart, change the chart type, make 
formatting changes, show or hide the legend or data table, or switch between displaying the 
data series by row and displaying it by column. The Chart menu allows you to make changes 
to the source data, add data to the chart, specify numerous chart options, change the location of 
the chart, and apply 3-D effects. The Chart menu does not, however, provide a command for 
creating a chart.  

 

 The Chart toolbar can also be displayed (or hidden) at any time by pointing to Toolbars 
on the View menu, and then clicking Chart. If you display the Chart toolbar before you create 
a chart, you can use it to create a chart. Select the cells that contain the data that you want to 
use in the chart, and then click Chart Type on the Chart toolbar. The chart will be displayed in 
the selected chart type on the same worksheet. 

 
Back 
 
 
Quick Tools 
 
Excel has a quick tool feature that will enable 
you to find the sum, min, max, count and average 
of selected cells without entering any formulas.  
Once cells with numbers are selected, excel will 
calculate and show the result at the center of the 
bottom toolbar. 
 
 
 
The default for most excel worksheets will be the sum function.  To change the calculation, right 
click on the bottom toolbar and choose the desired statistic (see next figure).  Your choices will 
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be as follows: 
 
None—does not perform a calculation 
Average—finds the average of selected cells that contain numbers 
Count—counts the number of selected non-blank cells 
Count Nums—counts the number of selected cells that contain numbers 
Max—finds the largest value of the selected cells that contain numbers 
Min—finds the smallest value of the selected cells that contain numbers 
Sum—finds the summation of the selected cells that contain numbers 
Anytime you select more than one cell, excel will calculate your choice on the bottom toolbar. 
 
Note: Excel will ignore numbers that are stored as text. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
        Right-click here, then choose one 
 
 
 
Back 
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